Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 31-07-2014 09:45:55

lamoet
N00b
Inscription : 31-07-2014
Messages : 3

Impossible de detecter mon Routeur Wifi sous Debian

Bonjour a tous,
Je vous expose mon problême, dans le cadre de mon projet de stage, je souhaite creer un hotspot-wifi a l'aide d'un modem routeur TP-link comme celui la, dans ma machine virtuel Debian. Je precise que ce n'est que pour creer un reseau dite local, en aucun cas je ne branche le routeur au reseau de l'entreprise.
Bref je branche le routeur a mon pc via un cable ethernet (seul connection possible), je lance ma machine virtuel debian (Que j'ai configuré en Bridge) j'installe wireless tools et configure mon /etc/network/interface comme ceci :

allow-hotplug eth0
iface eth0 inet dhcp
wireless-essid Maison
wireless-key1 0123-4567-89ab-cdef
wireless-key2 12345678
wireless-key3 s:mot_de_passe
wireless-defaultkey 2
wireless-keymode open

Mais lorsque je lance un iwconfig j'obtient un

lo     no wireless extension
eth0     no wireless extension

Doit je installer des drivers? un logiciel specifique? Sachant que pour la config sous windows il me suffit de taper 192.168.1.1 dans un navigateur pour afficher l'interface? (j'ai essayé de lancer l'interface sous debian via Lynx mais rien n'y fait, je n'arrive pas a y acceder!
J'ai fait enormement de recherche mais rien n'y fait je ne trouve aucune solution, je desespere!
Merci d'avoir pris le temp de me lire.

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#2 31-07-2014 15:08:00

lamoet
N00b
Inscription : 31-07-2014
Messages : 3

Re : Impossible de detecter mon Routeur Wifi sous Debian

Avancement du projet, finalement je me suit rendu compte que dans vmware la carte wifi n'est pas detecté comme tel, en effet en demarrant une machine virtuel xp j'ai vu que ma connection wifi était detecté comme une simple connection par cable.
J'ai donc basculé ma connection de machine virtuel en NAT, j'ai conecté le routeur par cable ethernet, j'ai installé telnet et la miracle en tapant telnet 192.168.1.1 , j'ai pu entrer dans le menu de reglage du routeur! big_smile
Bon par contre c'est la premiere fois que je fait sa et la je suit perdu, un petit coup de pouce pour installer un point d'acces wifi ne serait pas de trop! roll

Dernière modification par lamoet (31-07-2014 15:08:33)

Hors Ligne

#3 01-08-2014 13:45:15

kcdtv
Membre d'honneur
Lieu : Internacionaluña
Inscription : 31-03-2010
Messages : 4 246

Re : Impossible de detecter mon Routeur Wifi sous Debian

Sachant que pour la config sous windows il me suffit de taper 192.168.1.1 dans un navigateur pour afficher l'interface? (j'ai essayé de lancer l'interface sous debian via Lynx mais rien n'y fait, je n'arrive pas a y acceder!

L'accès à l'interface web d'administration du router ce fait par le navigateur web, peut importe que tu sois sous windows, mac ou linux wink
Attention : Tu utilises lynx qui est un navigateur en mode texte, commence par essayer avec un navigateur permettant d'interactuer avec une interface de configuration ( iceweasel par exemple )
As tu actualisé le système après installation dans la machine virtuelle?
As tu installé java et autres petits choses qui sont parfois nécessaires pour accéder aux interfaces de gestion?

Mais lorsque je lance un iwconfig j'obtient un

iwconfig permet de détecter les chipsets wireless USB, PCI, PCI-e et mini-PCI mais pas ce qui se passe par câble ethernet,
Pour voir tes interfaces ethernet (ethX) tu as la commande

ifconfig

Avancement du projet, finalement je me suit rendu compte que dans vmware la carte wifi n'est pas detecté comme tel, en effet en demarrant une machine virtuel xp j'ai vu que ma connection wifi était detecté comme une simple connection par cable

En effet, la gestion des interfaces wireless USB en machine virtuelle nécessite quelques manœuvres. wink


j'ai installé telnet et la miracle en tapant telnet 192.168.1.1 , j'ai pu entrer dans le menu de reglage du routeur! big_smile
Bon par contre c'est la premiere fois que je fait sa et la je suit perdu, un petit coup de pouce pour installer un point d'acces wifi ne serait pas de trop!

C'est que j'ai personnellement un peu de mal à comprendre où tu veux en venir avec telnet, virtualisation de debian + utilisation de l'interface wireless.
Tu veux dire quoi exactement par "installer" un point d'accès wifi?

Pourquoi passes tu par une machine virtuelle pour accéder à ton interface de configuration?

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Sujets similaires

Discussion Réponses Vues Dernier message
0 28 Aujourd'hui 18:55:55 par pwerrick
7 291 23-11-2016 18:46:08 par koala
9 1708 20-11-2016 03:45:46 par richie
8 276 17-11-2016 12:02:17 par koala
Routeur avec antenne amovible par le flibustier
0 231 07-11-2016 19:12:24 par le flibustier

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.028 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]