Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 04-10-2017 17:47:21

Freezer
N00b
Inscription : 03-10-2017
Messages : 4

Problème avec un partage de connexion par point d’accès wifi

Salut à tous

Depuis quelques jours j'essaye de créer un point d’accès wifi pour que mon fils puisse avoir accès a internet sur sa tablette mais de façon limité. J'en profite aussi pour comprendre et mieux utiliser cette facette.

J'ai réussi a ouvrir un point d’accès, à me connecter et pouvoir naviguer dessus pendant quelques heures, puis plus rien et j'ai du mal à comprendre pourquoi. Apres X essai au bout de quelques heures, tout refonctionne puis plus rien de nouveau après 5 mins de navigation, c'est aléatoire.

J'ai beau regarder les différents exemples sur le net, je vois pas du tout ou je peux me tromper. Je précise que je suis un débutant sur linux smile Je suis sur Kali 2 avec une Alpha AWUS036H, je vous montre le code et la config.

ap.sh

#!/bin/bash

LOG=/tmp/log.txt

#Reset
rm $LOG &> /dev/null
killall airbase-ng &> /dev/null
killall dhcpd isc-dhcp-server
airmon-ng stop wlan0mon &> /dev/null

#Acces point
ifconfig wlan0 up
airmon-ng start wlan0 &>> $LOG
airbase-ng -c 3 -e 'SafeWifi' wlan0mon &>> $LOG &
sleep 5

ifconfig at0 192.168.1.1 netmask 255.255.255.0
route add -net 192.168.1.0 netmask 255.255.255.0 gw 192.168.1.1

#Iptables
iptables --flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain

iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
iptables --append FORWARD --in-interface at0 -j ACCEPT

#Dhcpd service
dhcpd -cf /tmp/dhcpd.conf -pf /tmp/dhclient-eth0.pid at0
service isc-dhcp-server start

echo 1 > /proc/sys/net/ipv4/ip_forward

#Debug
echo ""
echo "Check Dhcp Service :"
netstat -anup |grep dhcp
echo ""

echo "Iptable  :"
iptables -t nat -L -n -v
echo ""

echo "Ip route  :"	
ip route
echo ""

echo "Ping eth0 test :"
ping -I eth0 google.com -c 1 |grep transmitted
echo ""

exit 0

dhcpd.conf

authoritative;
default-lease-time 600;
max-lease-time 7200;

subnet 192.168.1.0 netmask 255.255.255.0
{
	option subnet-mask 255.255.255.0;
	option broadcast-address 192.168.1.255;
	option routers 192.168.1.1;
	option domain-name-servers 8.8.8.8;
	range 192.168.1.1 192.168.1.100;
}

Au moment ou je lance le tout, tout se passe bien, J'obtiens ceci:

Internet Systems Consortium DHCP Server 4.3.5
Copyright 2004-2016 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Config file: /tmp/dhcpd.conf
Database file: /var/lib/dhcp/dhcpd.leases
PID file: /tmp/dhclient-eth0.pid
Wrote 2 leases to leases file.
Listening on LPF/at0/00:c0:ca:7b:74:fe/192.168.1.0/24
Sending on   LPF/at0/00:c0:ca:7b:74:fe/192.168.1.0/24
Sending on   Socket/fallback/fallback-net

Check Dhcp Service :
udp        0      0 0.0.0.0:67              0.0.0.0:*                           9737/dhcpd          
udp        0      0 0.0.0.0:19588           0.0.0.0:*                           9737/dhcpd          
udp6       0      0 :::19649                :::*                                9737/dhcpd          

Iptable  :
Chain PREROUTING (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 3 packets, 109 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain POSTROUTING (policy ACCEPT 2 packets, 58 bytes)
 pkts bytes target     prot opt in     out     source               destination         
    1    51 MASQUERADE  all  --  *      eth0    0.0.0.0/0            0.0.0.0/0           

Ip route  :
default via 192.168.0.254 dev eth0 proto static 
192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.216 
192.168.1.0/24 via 192.168.1.1 dev at0 scope link 
192.168.1.0/24 dev at0 proto kernel scope link src 192.168.1.1 

Ping eth0 test :
1 packets transmitted, 1 received, 0% packet loss, time 0ms

L'AP apparaît, je me connecte dessus et le serveur hcpd me fournit bien une ip, le subnet, routeur etc.

Infos fourni à la tablette:

Adresse IP                       192.168.1.2
Masque de sous reseau     255.255.255.0
Routeur                           192.168.1.1
Dns                                 8.8.8.8

C'est la que le problème survient, je n'ai aucune connexion internet sur la tablette. Je vais sur le navigateur, aucune page ne peut être lut et j'ai un message :

Un problème possible de Dns est survenu etc ...
ERR_NAME_NOT_RESOLVED

Est'il possible que le serveur Dns 8.8.8.8 de google pose problème ou évite mes demandes? J'ai essayé avec OpenDNs, idem.

Je sais pas du tout d'ou peu venir le souci, si une ame charitable trouve ou je merde, je suis preneur smile
Merci a vous!

Dernière modification par Freezer (04-10-2017 17:49:42)

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#2 04-10-2017 18:24:53

koala
Membre d'honneur
Lieu : In the sky
Inscription : 03-09-2010
Messages : 2 584

Re : Problème avec un partage de connexion par point d’accès wifi

Bonsoir cool


Je pense pas que le problème vienne du dns, pour commencer ajoute at0 qui n'est pas mentionné dans ton dhcp, ensuite a aucun moment je vois

ifconfig at0 up

Ça a son importance car si tu veux faire du sniff ou utiliser dnsspoof par la suite tu risquera d'avoir une erreur de ce genre:

No such interface, network is down

Et dernière chose pour éviter toute confusion essai d'activer le forwarding avant de mettre les règles iptables:

sysctl net.ipv4.ip_forward=1

IL y a peut-etre d'autre truc que je n'ai pas noté, me plonger dans les conf dhcp en fin de journée... voila quoi big_smile

Dernière modification par koala (04-10-2017 18:25:35)

Hors Ligne

#3 04-10-2017 18:31:37

Freezer
N00b
Inscription : 03-10-2017
Messages : 4

Re : Problème avec un partage de connexion par point d’accès wifi

Merci de ta réponse!

Je vais appliquer tout ça et je ferais un retour wink

Dernière modification par Freezer (04-10-2017 21:03:06)

Hors Ligne

#4 05-10-2017 17:21:00

Freezer
N00b
Inscription : 03-10-2017
Messages : 4

Re : Problème avec un partage de connexion par point d’accès wifi

Tout fonctionne beaucoup mieux en ayant fait les modifs, merci a toi big_smile

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Sujets similaires

Discussion Réponses Vues Dernier message
Épinglée :
254 147637 Hier 09:26:38 par Binawolf
2 224 13-10-2017 18:10:22 par Morpheus_Dotcom
16 889 08-10-2017 20:54:16 par lamefine
Problème wifite par Zigzagfault
2 186 28-09-2017 19:46:34 par coyotus
Probleme avec Fluxion par Fraise
0 514 22-09-2017 16:47:32 par Fraise

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.035 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]