Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 12-02-2010 00:46:00

uchronie
Membre
Inscription : 25-08-2009
Messages : 20

probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

hello!!! après avoir titillé les clé wep (sur le réseau de ma mère ^^), j'aimerais tester les rogues ap (et entre autre karmetasploit), mais le truque c'est que pour faire se genre de bidouille il faut mettre a jour framework 3 et aircrack-ng...

et donc j'ai testé la maj framework 3 et au bout d'un moment la mise a jour des "composants" s'arrête en plain cour et j'ai se message : svn: failed to add directory 'data/msfweb' : object of the same name already exists... et c'est tout, il n y a pas de suite ou de précision sur la fin de la maj.. dois-je prendre ca pour une erreur? (je présume :-S)

j'ai testé par la même occasion la mise a jour de aircrack-ng, et arrivé a la dernière partie (make install) ca charge plain de choses et puis j'ai se message : [*] run 'airodump-ng-oui-update' as root (or with sudo) to install or update airodump-ng oui file (internet connexion required)... et c est tout... cela veut il dire qu il a fini? ou c'est encore une cou... problème?

pardonnez moi mon ignorance, mais j'ai besoin de vous... j'ai fait de nombreuses recherches a propo des maj framework et aircrack-ng et j'ai pas trouver de problèmes similaire.. pouvez vous m'aider? j'suis triste et puni pour le moment lol

merci, signé crackeur punie (ou pourrit)

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#2 12-02-2010 01:01:21

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

Première chose à préciser : sous quelle version de BT es-tu ? 3 ou 4 ? (je parierais pour 3, sinon Aircrack serait à jour...)

Ensuite, l'outil fast-crack permet de faire les mises à jour d'Aircrack ET du Framework wink Voilà comment ca va (de mémoire) :

cd /pentest/exploits/fast-crack
python fast-crack.py -i

Là tu arrives à un menu, tu prends "updates", puis dans la liste qui suit, tu entres le chiffre pour le framework, et ensuite (quand il a fini) le chiffre pour Aicrack. Et ca devrait aller tout seul smile

Sinon, pour ton information, le message après la compilation d'Aircrack n'est pas une erreur, il te dit juste que si tu veux lancer [c]airodump-ng-oui-update [/c] tu as besoin d'une connexion internet. Si tu ne sais pas ce que c'est, c'est que tu n'en as pas besoin tongue (moi je sais ce que c'est, et je te le dis : tu n'en as pas besoin)
Pour tester l'Aircrack que tu viens de compiler, c'est de taper [c]./airmon-ng[/c], et de voir s'il prend la commande. Si ca marche, il te suffit de taper [c]make install[/c] pour copier les fichiers aux bons endroits smile

Hors Ligne

#3 12-02-2010 22:04:49

uchronie
Membre
Inscription : 25-08-2009
Messages : 20

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

j'ai fait comme tu m'as dit et j ai le meme type de message d'erreur pour la maj framework 3 :

[..................................................................................................]
U    /pentest/exploits/framework3/documentation/users_guide.pdf
A    /pentest/exploits/framework3/documentation/msfrpc.txt
A    /pentest/exploits/framework3/documentation/gendocs.sh
U    /pentest/exploits/framework3/documentation/users_guide.tex
A    /pentest/exploits/framework3/documentation/rpm
A    /pentest/exploits/framework3/documentation/rpm/metasploit.spec
D    /pentest/exploits/framework3/data/msfweb
svn: Failed to add directory '/pentest/exploits/framework3/data/msfweb': object of the same name already exists

et paf sa s'arrete... je precise que je suis bien sur backtrack 3 final en live cd et non sur bt4 car le script de karmetasploit est pour bt3 final. donc je sais pas pourquoi je suis punie, mais ca me fait chier j aimerais vraiment qu on puissent m'aider :-(

tu peut m'aider? ou quelqu un peut il essayer de m'aider? esque cela pourrait provenir du fait que je suis sous live cd et que les maj ne peuvent donc pas s'effectuer correctement? ou esque malgré le live cd certains ont quand meme reussit? je vous remercie et espere avoir une reponses positive

cordialement

(pardon pour les fautes c est pas tres cool pour les gens qui lisent mais j'ai de grosses lacune)

Dernière modification par uchronie (12-02-2010 22:06:07)

Hors Ligne

#4 13-02-2010 00:18:27

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

Visiblement, il a du mal à remplacer des composants existants... hmm Tu peux toujours essayer de supprimer manuellement les fichiers en question ([c]rm -r /pentest/exploits/framework3/data/msfweb[/c] par exemple). mais s'il y en a beaucoup, ca va être long...

Une autre solution, fournie par cette page de Brico-wifi --> metasploit version 3.3.1 dispo en download [brico-wifi] (dans les commentaires). Ca revient à tout effacer et tout réinstaller :

cd /pentest/exploits/
rm -rf framework3
svn co https://www.metasploit.com/svn/framework3/trunk/
mv trunk framework3

Comme l'utilisateur l'a mentionné, la version ainsi mise à jour propose beaucoup moins d'exploits, et ca je ne sais pas pourquoi... Peut-être que BackTrack proposait des exploits, et qu'ils ont été supprimés par les commandes ci-dessus. Perso je pense plutôt que la dernière version a été "nettoyée" de tous les exploits obsolètes.

Sinon, tu peux aussi aller sur le site officiel, télécharger l'archive de la 3.3.1, et l'installer toi même wink

[EDIT] Je viens de réussir une mise à jour avec les commandes suivantes :

rm -r /pentest/exploits/framework3/data/msfweb/
svn update /pentest/exploits/framework3/

Toujours aussi "peu" d'exploits, mais apparemment c'est à jour smile Par contre je peux pas garantir que Karmetasploit fonctionne toujours tel quel wink

Au cas où : Installation on BackTrack Linux (2,3,4) [Metasploit Wiki]

Dernière modification par antares145 (13-02-2010 00:43:49)

Hors Ligne

#5 13-02-2010 12:55:54

uchronie
Membre
Inscription : 25-08-2009
Messages : 20

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

merci je vais tester tout ca en arrivant chez moi!!! en revanche quelque chose m'intrigue!!! pourquoi dits tu que karmetasploit ne fonctionnera peut être plus?

le script est trop vieux? as tu retesté le script et constater un probleme?

et les autres? merci

Hors Ligne

#6 13-02-2010 13:03:40

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

Je connais pas du tout Karmetasploit (enfin, si, mais je l'ai jamais testé), donc je ne sais pas trop quelles sont ses dépendances critiques (au niveau de metasploit, entre autre).

Mais je viens de jeter un œil vite fait, à priori ca a l'air OK, à toi de me dire si ca fonctionne correctement smile

Hors Ligne

#7 14-02-2010 20:05:30

uchronie
Membre
Inscription : 25-08-2009
Messages : 20

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

hello, encore merci pour ta patience
dans toute les techniques que tu m'as conseillé, j'ai opté pour l'installation manuelle (j'aime bien avoir les mise a jour stoqué sur ma clé usb)
j'ai donc telechargé la derniere mise a jour (3.3.3) pour linux, et il y avais la version 32 et 64 bit (j'ai pris la 64 bit sans savoir si c'était une bonne idée ou non par rappor a l'autre)
pour se qui est de l'installation, j ai regardé sur le net pour installer un .run et j'ai donc procedé comme ceci :

#chmod +x tonfichier.run
sh ./toto.run

jusqu ici tout va bien, l'installation debute, MAIS J AI UN PETIT DOUTE SUR L'INSTALLATION et tu/vous allez comprendre pourquoi (voici un copier collé du deroulement) :





Metasploit Framework v3.3.3 Release
    Report Bugs: [email protected]

This installer will place Metasploit into the /opt/metasploit3 directory.
Continue (yes/no) > yes
Extracting the Metasploit operating environment...

Extracting the Metasploit Framework...

Installing links into /usr/local/bin...

Installation complete.

Would you like to automatically update Metasploit?
AutoUpdate? (yes/no) > yes
mktemp: cannot create temp file cronXXXXX: Invalid argument
./installer.sh: line 77: $CRON: ambiguous redirect
./installer.sh: line 78: 1: ambiguous redirect
crontab 2.3.3
crontab file <opts>  replace crontab from file
crontab -    <opts>  replace crontab from stdin
crontab -u user      specify user
crontab -l [user]    list crontab for user
crontab -e [user]    edit crontab for user
crontab -d [user]    delete crontab for user
crontab -c dir       specify crontab directory

Would you like to update Metasploit right now?
Update? (yes/no) > yes

Updating Metasploit from https://www.metasploit.com/svn/framework3/trunk...
/opt/metasploit3/app/msfupdate: line 12: /opt/metasploit3/app/svn: cannot execute binary file

Error: cleaning up the SVN directory and retrying...
/opt/metasploit3/app/msfupdate: line 19: /opt/metasploit3/app/svn: cannot execute binary file
/opt/metasploit3/app/msfupdate: line 20: /opt/metasploit3/app/svn: cannot execute binary file

Error: please check connectivity to the following URL:
    https://www.metasploit.com/svn/framework3/trunk

Launch the Metasploit console by running 'msfconsole'

Exiting the installer...





en gros, quand il m'a demandé d'installer framework 3.3.3 j'ai dit oui, et apres le deroulement de l'installation j'ai eu le message comme quoi l'installation était belle et bien complete (ouffff)
par la suite (si j ai bien compris) il ma demandé si je voulais que les mise a jour soient automatique pour apres, et j ai dit oui (pas de message d'erreur en vue)
PAR CONTRE, au moment d'installer les dernieres mise a jour, j ai plusieur message d'erreur "cannot execute binary file" et d'autre truques......
je me suis dit que c'était logique vu que j'ai telechargé la derniere version de framework metasploit!!!
j ai donc lancé framework 3 dans : backtrack, puis penetration, puis framework 3, puis framework3-msfc, puis je CONSTATE qu il y a ecrit  : msf v3.2-release

(alor que je suis sencé avoir la 3.3.3), c'est moi qui a rien compris ou il y a belle et bien un probleme? (pourtemp tout porte a croire que c est a jour.... pouvez vous m'eclairer? (je pourrais tres bien tester karmetasploit mais si celui ci bug je vais penser a un probleme de mise a jour donc je prefere etre sur de proceder etape par etape)

merci de votre patience, cordialement, uchronie

Hors Ligne

#8 14-02-2010 21:12:52

Veidam
Membre Indispensable
Lieu : us
Inscription : 11-02-2010
Messages : 530

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

en faite metasploit fonctionne avec la version svn de aircrack as tu fait son installation ?

make SQLITE=true
&&
make SQLITE=true install

une piste peut être http://trac.aircrack-ng.org/svn/trunk/

voici celui que j'utilise aircrack-ng-svn-trunk-current.tar.gz    rc1 qui fonctionne bien

Hors Ligne

#9 14-02-2010 23:13:22

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

Première chose, si tu ne connais pas la différence entre 32 bits et 64 bits, tu es sans doute en 32, donc tu aurais pris la mauvaise version. Pour vérifier, tu tapes en console "uname -a" pour voir si tu es en i386 ou amd64.

Ensuite, maintenant que tu as installé Metasploit, tu peux tenter la mise à jour par svn : [c]svn update /opt/metasploit3/[/c] (ou bien "/opt/metasploit3/msf3"). Il est possible que tu aies un avertissement sur le certificat (qu'on t'invite à accepter ou refuser), c'est peut-être ca qui fait foirer l'update "automatique". Si ca ne marche pas, essaie de voir si la commande "msfupdate"est reconnue (elle devrait).

Hors Ligne

#10 14-02-2010 23:51:49

uchronie
Membre
Inscription : 25-08-2009
Messages : 20

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

hello, apres un paquet de tentatives j ai enfin reussi a metre a jour framework 3 officielement (constatation dans le prog avec le numero de la version), j'ai fait comme veidam m'a dit (suprimer manuelement le fichier qui posais probleme) et je dit merci beaucoup!! au moment ou l'erreur est apparut j'ai suprimer le dosser, et j'ai refait une maj (qui a repris son travaille la ou j'était coinssé) J'ESPERE DONC QUE LE FAIT D'AVOIR LANCER ET CORRIGER UNE MAJ CORROMPU NE ME POSERA PAS PROBLEME PAR LA SUITE, mais le "Updated to revision 8497" a la fin ma rassuré lol!!!

maintenant que j'ai avancer grace a vous, j'ai encor quelque petites questions mais qui ne devraient pas poser problemes :

- pour framework 3, j ai la sertitude qu il a été mis a jour (avec la technique que j'ai employé pour installer la maj j'espere que des bugs n'apparetron pas, je croise les doigts), en lancant le prog la version a changé, EN REVENCHE, comment puis-je avoir la sertitude que la nouvelle version d'aircrack est bien a jour? une sorte de "a propo" version "linux" pourrais m'eclairer, merci

[EDIT] : j'ai tapé aircrack-ng et en haut du shell il y a ecrit "Aircrack-ng 1.0 r1662 - (C) 2006, 2007, 2008, 2009 Thomas d'Otreppe", j'ai cherché sur le net et si j'ai bien compris c'est belle et bien la derniere maj.. confirmez moi au cas ou je me trompe, mais ducou j'ai repondu comme un grand a cette question lol

- peut on telecharger et installer manuellement les mises a jour plutot que de taper une ligne de commande qui le fait automatiquement via les sites internet conserné? (je prefere avoir les mises a jour stoqué sur ma clé), si oui pouvez vous me dire ou je peut trouver les maj de framework 3 (et non le programme), puis pareil pour aircrack "trunk"? (pour se qui est des commandes pour l'instalation je me suis deja penché sur la question, en revenche j'ai peut etre mal cherché mais j ai pas trouver les maj pour les deux)

merci pour votre aide, j'avence lentement mais surment

Dernière modification par uchronie (15-02-2010 00:00:18)

Hors Ligne

#11 15-02-2010 00:19:01

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

Hé ben voilà smile Bien joué !

Alors pour tes questions :
- je confirme ton auto-réponse pour Aircrack, la version 1 (r1662) est bien la dernière en date ! smile Par contre, normalement la mise à jour d'Aircrack n'est pas liée à celle de Metasploit wink
- pour les mises à jour embarquées, c'est possible pour Aircrack (il suffit de prendre l'archive tar.gz sur ta clé usb, et de faire un [c]make && make install[/c] pour l'installer en mode live), mais pour le Framework je ne pense pas que c'est faisable hmm Il change très souvent (puisque des exploits sont régulièrement ajoutés), et ils ne vont pas passer leur temps à refaire un package tous les 2 jours... Donc la seule chose que tu peux "transporter" c'est l'archive de la dernière version publiée (ici la 3.3), mais elle ne sera pas à jour. Par contre, maintenant que tu as fait une installation "propre", normalement une simple commande du type "svn update" (comme je t'ai donné plus haut) devrait te permettre de faire la mise à jour en 3 minutes (si tu as accès au net...) smile

Hors Ligne

#12 15-02-2010 00:33:29

uchronie
Membre
Inscription : 25-08-2009
Messages : 20

Re : probleme et question sur maj "framework 3" et "aircrack-ng" :-( merci

ok pour la maj embarqué, c'est cool et c'est une reponse rapide ^^

en revenche pour framework je suis un peut triste vu que c'est pas possible,  mais une question me vien a l'esprit... dans le topique de karmetexploit il est precisé qu il faut metre a jour la version de framework... esque c'est "a partir" d une certaine version que karmetexploit (et toute les autres manipes) sont exploitables? ou esqu il faut etre a la pointe des mises a jour pour fair marcher tout ca? autrement dit, esqu avec la derniere version de framework qui est sur le site (SANS LES MISES A JOUR), cela marchera quand meme celon toi?

[edit pour precision] en gros je voudrais me metre en situation reel pour voir si une personne malintentionné pourrais reussir une attaque rogue AP (ou autre dans le meme genre) sans avoir internet, si moi (qui n'est pas tres fort) peut reussir a le fair en le testant sur moi meme, tout le monde peut y arriver!! j'ai pas de grosse conaissence et c'est ca que je trouve impressionant, c'est a la fois "compliqué" (quand ont connais pas) et simple a la fois, ca fait froid dans le dos

Dernière modification par uchronie (15-02-2010 00:41:14)

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Sujets similaires

Discussion Réponses Vues Dernier message
4 144 04-12-2016 16:20:59 par pwerrick
aircrack-ng par baltigor
2 138 30-11-2016 20:46:48 par koala
Problème reaver par Antho3674
4 301 15-11-2016 22:05:12 par kcdtv
7 313 26-09-2016 15:52:41 par ElliotV
3 337 14-08-2016 10:22:07 par MiscL

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.045 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]