Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 11-09-2011 16:33:20

h9k
Membre Radioactif
Inscription : 09-08-2011
Messages : 74

problème metasploit armitage msfupdate backtrack5r1

bonjour,


j'ai backtrack 5 r1 gnome 64bits, et je pouvai démarrer armitage sans problèmes, en cliquant dans le menu : applications/backtrack/exploitation tools/network exploitation tools/metasploit framework/armitage

mais après avoir cliqué sur : applications/backtrack/exploitation tools/network exploitation tools/metasploit framework/msfupdate (ce qui met metasploit a jour avec subversion il me semble) et ben armitage ne marche plus.. je clique sur Start MSF ,puis la petite fenetre de chargement charge jusqu'au bout(plus lentement) puis plus rien.

et même chose quand je clique sur : applications/backtrack/exploitation tools/network exploitation tools/metasploit framework/msfcli ou applications/backtrack/exploitation tools/network exploitation tools/metasploit framework/msfconsole : l'un et l'autre me renvoie ça :

/opt/framework/msf3/lib/msf/core/exploit/snmp.rb:2:in `require': no such file to load -- snmp (LoadError)
    from /opt/framework/msf3/lib/msf/core/exploit/snmp.rb:2:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core/exploit/mixins.rb:47:in `require'
    from /opt/framework/msf3/lib/msf/core/exploit/mixins.rb:47:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:217:in `require'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:217:in `<class:Exploit>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:29:in `<module:Msf>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:4:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core.rb:52:in `require'
    from /opt/framework/msf3/lib/msf/core.rb:52:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui/console/driver.rb:1:in `require'
    from /opt/framework/msf3/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui/console.rb:10:in `require'
    from /opt/framework/msf3/lib/msf/ui/console.rb:10:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui.rb:10:in `require'
    from /opt/framework/msf3/lib/msf/ui.rb:10:in `<top (required)>'
    from /opt/framework/msf3/msfconsole:118:in `require'
    from /opt/framework/msf3/msfconsole:118:in `<main>'
[email protected]:~#

merci de votre aide

Dernière modification par h9k (11-09-2011 21:09:48)

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#2 11-09-2011 21:10:14

h9k
Membre Radioactif
Inscription : 09-08-2011
Messages : 74

Re : problème metasploit armitage msfupdate backtrack5r1

et quand dans le menu je clique sur : applications/backtrack/exploitation tools/network exploitation tools/metasploit framework/msfupdate

ça donne ça :

[*]
[*] Attempting to update the Metasploit Framework...
[*]

svn: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
À la révision 13718.
[email protected]:~#

Hors Ligne

#3 11-09-2011 21:16:08

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : problème metasploit armitage msfupdate backtrack5r1

La mise à jour via SVN, par définition, synchronise ta version avec les fichiers de développement. Ceux-ci peuvent être buggés, instables, foireux ou les 3 à la fois, donc ce genre de "couac" n'est tellement surprenant...

Ca donne quoi si tu tapes cette commande ?

msfconsole
# Si ça foire, tape la commande suivante puis réessaie : 
# svn up /opt/framework/*

Tant qu'à faire, tu peux faire une mise-à-jour complète du système, avec un peu de chances, les dépendances genre Ruby ont été mises à jour dans les dépôts et ça règlera le problème...

apt-get update && apt-get dist-upgrade

Je déplace ton topic dans la section "Outils de pentest" où il a + sa place.

Hors Ligne

#4 11-09-2011 22:07:09

h9k
Membre Radioactif
Inscription : 09-08-2011
Messages : 74

Re : problème metasploit armitage msfupdate backtrack5r1

la commande

svn up /opt/framework/*

me donne ça :

[email protected]:~# svn up /opt/framework/*
'/opt/framework/app' omis
'/opt/framework/bin' omis
'/opt/framework/common' omis
'/opt/framework/config' omis
'/opt/framework/icons' omis
'/opt/framework/java' omis
'/opt/framework/lib' omis
'/opt/framework/licenses' omis
U    /opt/framework/msf3/external/source/gui/msfguijava/src/msfgui/MainFrame.java
U    /opt/framework/msf3/external/source/gui/msfguijava/src/msfgui/DraggableTabbedPane.java
U    /opt/framework/msf3/external/source/gui/msfguijava/src/msfgui/MeterpFileBrowser.java
U    /opt/framework/msf3/data/gui/msfgui.jar
Actualisé à la révision 13719.
Résumé des conflits :
  Chemins omis : 8
'/opt/framework/postgresql' omis
'/opt/framework/properties.ini' omis
'/opt/framework/ruby' omis
'/opt/framework/run.sh' omis
'/opt/framework/sbin' omis
'/opt/framework/scripts' omis
'/opt/framework/share' omis
'/opt/framework/svn' omis
'/opt/framework/tools' omis
'/opt/framework/uninstall' omis
[email protected]:~#

mais après quand je lance msfconsole, c'est toujours pareil.



visiblement il y a déja eu des bugs similaires :

http://dev.metasploit.com/redmine/issues/3713
http://dev.metasploit.com/redmine/issues/3445


la commande

apt-get update && apt-get dist-upgrade

ne résout rien


suis je le seul qui a ce bug ??

Dernière modification par h9k (11-09-2011 23:04:08)

Hors Ligne

#5 12-09-2011 01:03:17

h9k
Membre Radioactif
Inscription : 09-08-2011
Messages : 74

Re : problème metasploit armitage msfupdate backtrack5r1

bon ben j'ai trouvé une solution, en fait il faut installer la dernière version qui ne bugue pas avec cette commande :

svn up -r 13676 /opt/framework/*

qui met metasploit a la version 13676 ,la dernière qui marche aujourd'hui.



le logiciel metasploit est installé dans le dossier /opt/framework ? entièrement ?

que représente le dossier /pentest/framework2 ??

Dernière modification par h9k (12-09-2011 01:04:37)

Hors Ligne

#6 12-09-2011 02:30:42

Fuji
Membre Irremplaçable
Lieu : Saint Script-sur-Shell
Inscription : 13-12-2010
Messages : 783

Re : problème metasploit armitage msfupdate backtrack5r1

Le framework 2 est l'ancienne version de metasploit développée en langage Perl, contrairement à la version 3 récente écrite en Ruby. Il semble que le framework2 a été abandonné et n'est plus mis à jour.

Hors Ligne

#7 12-09-2011 16:41:37

goliate
Membre Irremplaçable
Inscription : 06-12-2009
Messages : 1 413
Site Web

Re : problème metasploit armitage msfupdate backtrack5r1

Perso hier soir j'ai pu utiliser armitage je jouer vite fait avec, et d'un coup d'un seule il c'est mis a planter.Donc aujourd’hui' j'ai installer la version KDE, peut être que ton problème viens de la version gnome.


só deus podem me julgar
719895banniere3.gif
só deus podem me julgar

Hors Ligne

#8 12-09-2011 19:59:11

ghacks
Nouveau membre
Inscription : 27-06-2011
Messages : 8

Re : problème metasploit armitage msfupdate backtrack5r1

je vous suggere de faire quoi ce soit backtrack latest Release je le update le noyau ou upgrade
apt-get update && apt-get dist-upgrade le commande.

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Sujets similaires

Discussion Réponses Vues Dernier message
3 319 05-10-2017 17:21:00 par Freezer
Problème wifite par Zigzagfault
2 183 28-09-2017 19:46:34 par coyotus
Probleme avec Fluxion par Fraise
0 506 22-09-2017 16:47:32 par Fraise
0 494 01-09-2017 16:10:37 par mac89512
7 439 25-08-2017 20:41:41 par Fab955

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.027 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]