Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 09-10-2011 11:54:11

nathan
Nouveau membre
Inscription : 10-08-2011
Messages : 9

Sslstrip, probléme de page blanche.

Bonjour a tous,

Voila j'essaye d'utiliser sslstrip après être en position de man in the middle.
J'ai mis les bonnes règles iptables j'ai activé l'ip forwarding ect...
Mais quand je consulte une page, sslstrip renvoit une page blanche au PC victime... :s
Je ne reçois aucun mot de passe dans la sortie sslstrip.
J'utilise Ubuntu et mon problème est similaire a celui évoqué sur le poste : http://www.crack-wifi.com/forum/viewtopic.php?id=2475
Mais je n'ai pas trouvé de solution a ce problème. :s

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#2 09-10-2011 14:24:19

koala
Membre d'honneur
Lieu : In the sky
Inscription : 03-09-2010
Messages : 2 314

Re : Sslstrip, probléme de page blanche.

Je me souviens avoir eu un problème similaire, je me souviens plus trop comment je l'ai réglé mais voila les lignes que j'ai dans 1 de mes scripts concernant sslstrip:

echo 1 > /proc/sys/net/ipv4/ip_forward ;
xterm -hold -e sslstrip -a -k -f &> /dev/null & sslpid=$

et dans un autre l'orsque'une rogue est lancé:

iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 10000 ;
cd /root/sslstrip-0.7 ;
xterm -hold -e python sslstrip.py -p -w ismaetest.txt &> /dev/null &

voila, bonne chance wink

Dernière modification par koala (09-10-2011 14:24:42)

Hors Ligne

#3 09-10-2011 23:22:38

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Sslstrip, probléme de page blanche.

A première vue je dirais que c'est une mauvaise configuration dans les redirections et le transfert de connexion (un log Wireshark nous en dirait plus). le truc, c'est qu'avec si peu d'infos on a du mal à juger hmm

Si tu veux qu'on t'aide, il faut que tu nous détailles tout ce que tu as fait (commandes et résultats), ainsi que l'adresse du tuto que tu appliques (si c'est le cas).

Hors Ligne

#4 11-10-2011 17:06:18

nathan
Nouveau membre
Inscription : 10-08-2011
Messages : 9

Re : Sslstrip, probléme de page blanche.

Ba à la base j’envoie les ARP avec un programme que j'ai développé moi même.
Mais c'est pas sa le problème car j'ai essayé également avec arpspoof via les commandes suivantes :
[c]arpspoof -i eth0 -t ip_victime_1 ip_victime_2
arpspoof -i eth0 -t ip_victime_2 ip_victime_1[/c]

J'ai aussi fais :
[c]sudo -s
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 15000
sslstrip -w log.txt -a -l 15000 -f[/c]

Et quand je vais sur le PC victime sur http://google.fr/ j'obtiens une page blanche.

J'ai essayé les commandes de koala mais sa n'a pas fonctionné...

PS : le tuto que j'ai suivis est : http://www.crack-wifi.com/tutoriel-ssls … -https.php

Dernière modification par nathan (11-10-2011 18:05:15)

Hors Ligne

#5 11-10-2011 20:58:55

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Sslstrip, probléme de page blanche.

Commence par isoler la cause du problème !
- Fais un ARP spoofing simple (avec ton programme ou arpspoof), et vérifie si le cache de la victime est bien empoisonné
- active l'ip forward, et regarde si un transfert simple de trafic fonctionne (la victime empoisonnée doit pouvoir surfer de façon transparente)
- active le transfert iptables et regarde avec Wireshark si tu reçois du trafic sur le port 15000

Si tout ça fonctionne, c'est un bug de sslstrip qu'il faudra trouver mais j'ai dans l'idée que le problème se trouve dans les étapes que je viens de citer wink

Hors Ligne

#6 12-10-2011 09:55:20

nathan
Nouveau membre
Inscription : 10-08-2011
Messages : 9

Re : Sslstrip, probléme de page blanche.

J'ai vérifié le cache ARP, il est bien empoisonné.
J'ai activé l'ip_forward sans toucher aux iptables nis sslstrip le trafic passe bien.
Quand je mes en place mon iptables sans toucher à sslstrip, le trafic http ne passe plus (logique)
Quand je mes en écoute sslstrip sur le port ou j'ai redirigé le trafic, j'obtiens la page blanche, c'est donc sslstrip qui me renvois la page blanche...

Voici un fichier de capture wireshark ou 172.16.140.27 et la victime qui se connecte sur google et 172.16.0.1 le second PC empoisonné. 172.16.1.29 est le PC attaquant d’où a été faite la capture.

http://www.megaupload.com/?d=2XC2VRS2

Hors Ligne

#7 12-10-2011 10:12:33

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Sslstrip, probléme de page blanche.

Il a l'air corrompu ton fichier, en tout cas d'après Wireshark... Mauvais upload ?
[MD5=94ea317b17e15fc9b7e63ed32e779163]

Sinon, si tu essaies d'aller sur une autre page, ça fait la même chose ? Sur du HTTPS aussi ? Essaie de lancer sslstrip sur le port 10000 (son port par défaut) et sans option particulière :

iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-ports 10000 
python sslstrip.py -w logfile

Sinon, tu utilises quelle version de BackTrack (si c'est BT5, précise Gnome||KDE et 32||64 bits) ? Quelle version de sslstrip ? Tu as des messages d'erreur dans la console où tu as lancé sslstrip ?

Hors Ligne

#8 14-10-2011 12:59:00

nathan
Nouveau membre
Inscription : 10-08-2011
Messages : 9

Re : Sslstrip, probléme de page blanche.

Salut antares145,

J'ai refais plusieurs captures, une sur le client et sur le PC attaquant, tu peus télécharger les fichiers a cette adresse : http://jzyra.free.fr/capture/
-capture.pcap a été fais sur le poste client
-capture2.pcap sur le poste attaquant

Normalement ils ne sont pas corrompus cette fois.
J'utilise sslstrip 0.9.
Je n'utilise pas Backtrack, mais Ubuntu 10 version LTS.
J'utilise GNOME, je suis en 64 bits.

J'ai fais exactement comme tu m'as dis, j'ai toujours le même problème de page blanche quand je vais sur un site.

Et je n'ai aucun message d'erreur dans le terminal ou j'ai lancé sslstrip.

Merci de ton aide,

Dernière modification par nathan (14-10-2011 17:49:18)

Hors Ligne

#9 14-10-2011 20:25:27

koala
Membre d'honneur
Lieu : In the sky
Inscription : 03-09-2010
Messages : 2 314

Re : Sslstrip, probléme de page blanche.

Et je n'ai aucun message d'erreur dans le terminal ou j'ai lancé sslstrip.

tu es sur? t'as checké les log? c'est étonnant, si ça bug toujours, pour voir si ça vient bien de sslsttrip met la version 0.7 en test hisoire de voir si ta la meme erreur concernant les pages blanches.


Ps: vu ta capture par sécurité change tes mots de passe et éfface tes cookies

Hors Ligne

#10 21-10-2011 16:42:03

nathan
Nouveau membre
Inscription : 10-08-2011
Messages : 9

Re : Sslstrip, probléme de page blanche.

J'ai essayé avec la version 0.7, même problème... :s

Hors Ligne

#11 21-10-2011 18:10:37

koala
Membre d'honneur
Lieu : In the sky
Inscription : 03-09-2010
Messages : 2 314

Re : Sslstrip, probléme de page blanche.

Apparemment tu n'est pas le seul a avoir ce problème, il y a déja des topic la dessus:

Problème sslstrip

Hors Ligne

#12 24-10-2011 20:15:18

nathan
Nouveau membre
Inscription : 10-08-2011
Messages : 9

Re : Sslstrip, probléme de page blanche.

Ba oui, j'ai vus sa, c'est le lien que j'ai mis sur mon premier message de ce topic... wink
Mais bon personnes n'a jamais trouvé de solution a ce problème ?
Apparemment sa marche sur Backtrack, et c'est sur Ubuntu que sa fonctionne pas, mais sa n'a pas de sens... hmm

Dernière modification par nathan (24-10-2011 20:19:22)

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Sujets similaires

Discussion Réponses Vues Dernier message
Problème reaver par Antho3674
4 294 15-11-2016 22:05:12 par kcdtv
3 332 14-08-2016 10:22:07 par MiscL
5 725 18-07-2016 23:13:58 par kcdtv
5 1848 13-07-2016 15:56:51 par jaues007
Problème airodump-ng par Skriix94
5 673 11-07-2016 23:14:38 par kcdtv

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.031 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]