Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 19-11-2011 15:27:38

HappyDad
Membre V.I.P.
Lieu : Awus036h
Inscription : 14-11-2009
Messages : 282
Site Web

Résoudre l'erreur "Invalid configuration file" sur VMWare [astuce]

Salut les amis smile

Aujourd'hui je vais partager avec vous une petite astuce que j'ai trouvé après avoir pas mal galéré avec VMWare. En voulant booter la version VMWare de Backtrack 4 je suis tombé sur une erreur "Invalid configuration file":

VMWare a écrit :

Invalid configuration file: File "D:/machin.vmx" was created by a VMware product with more features than this version of VMware Workstation and cannot be used with this version of VMware Workstation. Cannot open configration file machin.vmx.

Je vous montre de quoi il s'agit. Je veux booter cette VM sous VMWare:

1-BT-4-vmware.png
Image taille réelle ici.

Je clique sur le bouton pour démarrer la VM, et là bam:

2-erreur-invalid-configuration-file.png
Image taille réelle ici.

Ou la vilaine erreur que voila! Je cherche un peu sur mon forum préféré et je trouve un post de M1ck3y disant qu'il faut modifier un fichier de conf (fichier .vmx de la machine virtuelle). Après quelques tests, ça a en effet fonctionné. Au boot de la machine virtuelle on tombe sur ce message:

3-create-new-id.png
Image taille réelle ici.

Là il faut juste cliquer sur "Create" pour créer un nouvel UUID (ce sont les identifiants uniques de la machine virtuelle), et ensuite le boot se lance:

4-boot-bt4.png
Image taille réelle ici.

Oui c'est ok ça démarre smile :

5-bt4-boot-ok.png
Image taille réelle ici.

Bon alors qu'est ce qui s'est passé exactement? Et bien j'ai juste édité une ligne dans le fichier de conf de la VM. Voici mon fichier BackTrack4-Final.vmx original quand j'avais l'erreur:

.encoding = "windows-1252"
config.version = "8"
virtualHW.version = "7"
maxvcpus = "4"
scsi0.present = "TRUE"
scsi0.virtualDev = "lsilogic"
memsize = "768"
scsi0:0.present = "TRUE"
scsi0:0.fileName = "BackTrack4-Final.vmdk"
ide1:0.present = "TRUE"
ide1:0.fileName = "auto detect"
ide1:0.deviceType = "cdrom-raw"
ethernet0.present = "TRUE"
ethernet0.connectionType = "nat"
ethernet0.wakeOnPcktRcv = "FALSE"
ethernet0.addressType = "generated"
usb.present = "TRUE"
ehci.present = "TRUE"
sound.present = "TRUE"
sound.fileName = "-1"
sound.autodetect = "TRUE"
pciBridge0.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
roamingVM.exitBehavior = "go"
displayName = "BackTrack4-Final"
guestOS = "ubuntu"
nvram = "BackTrack4-Final.nvram"
virtualHW.productCompatibility = "hosted"
extendedConfigFile = "BackTrack4-Final.vmxf"
ide1:0.startConnected = "FALSE"
ethernet0.generatedAddress = "00:0c:29:47:e6:79"
tools.syncTime = "FALSE"
uuid.location = "56 4d d5 54 f7 b0 31 f7-e5 61 e2 4b 22 47 e6 79"
uuid.bios = "56 4d d5 54 f7 b0 31 f7-e5 61 e2 4b 22 47 e6 79"
cleanShutdown = "TRUE"
replay.supported = "FALSE"
unity.wasCapable = "FALSE"
replay.filename = ""
scsi0:0.redo = ""
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "16"
usb.pciSlotNumber = "32"
ethernet0.pciSlotNumber = "33"
sound.pciSlotNumber = "34"
ehci.pciSlotNumber = "35"
vmci0.pciSlotNumber = "36"
vmotion.checkpointFBSize = "16777216"
ethernet0.generatedAddressOffset = "0"
vmci0.id = "-1904229542"
ide1:0.autodetect = "TRUE"
floppy0.present = "FALSE"

isolation.tools.hgfs.disable = "TRUE"
tools.upgrade.policy = "manual"

Et voila mon fichier modifié qui fonctionne:

.encoding = "windows-1252"
config.version = "8"
virtualHW.version = "6"
maxvcpus = "4"
scsi0.present = "TRUE"
scsi0.virtualDev = "lsilogic"
memsize = "768"
scsi0:0.present = "TRUE"
scsi0:0.fileName = "BackTrack4-Final.vmdk"
ide1:0.present = "TRUE"
ide1:0.fileName = "auto detect"
ide1:0.deviceType = "cdrom-raw"
ethernet0.present = "TRUE"
ethernet0.connectionType = "nat"
ethernet0.wakeOnPcktRcv = "FALSE"
ethernet0.addressType = "generated"
usb.present = "TRUE"
ehci.present = "TRUE"
sound.present = "TRUE"
sound.fileName = "-1"
sound.autodetect = "TRUE"
pciBridge0.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
roamingVM.exitBehavior = "go"
displayName = "BackTrack4-Final"
guestOS = "ubuntu"
nvram = "BackTrack4-Final.nvram"
virtualHW.productCompatibility = "hosted"
extendedConfigFile = "BackTrack4-Final.vmxf"
ide1:0.startConnected = "FALSE"
ethernet0.generatedAddress = "00:0c:29:ce:de:97"
tools.syncTime = "FALSE"
uuid.location = "56 4d f8 50 a4 58 3d 53-8a 20 cc 04 4b ce de 97"
uuid.bios = "56 4d f8 50 a4 58 3d 53-8a 20 cc 04 4b ce de 97"
cleanShutdown = "TRUE"
replay.supported = "FALSE"
unity.wasCapable = "FALSE"
replay.filename = ""
scsi0:0.redo = ""
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "16"
usb.pciSlotNumber = "32"
ethernet0.pciSlotNumber = "33"
sound.pciSlotNumber = "34"
ehci.pciSlotNumber = "35"
vmci0.pciSlotNumber = "36"
vmotion.checkpointFBSize = "16777216"
ethernet0.generatedAddressOffset = "0"
vmci0.id = "-1904229542"
ide1:0.autodetect = "TRUE"
floppy0.present = "FALSE"

isolation.tools.hgfs.disable = "TRUE"
tools.upgrade.policy = "manual"

En fait j'ai juste édité la 3ème ligne, le paramètre virtualHW.version. La VM avait été générée avec une version 7 de VMWare, j'ai passé ce chiffre à 6 pour faire croire à ma version de VMWare que la VM est compatible, résultat plus d'erreur,  on recrée l'UUID et ça boote big_smile


logo-awus036h-petit.png logo-wifi-highpower-175x60.jpg logo-luxury.jpg logo-backtrack-5-special-edition.png

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Sujets similaires

Discussion Réponses Vues Dernier message
1 51 Hier 12:06:44 par david_01
Configuration AP Cisco par Vincent_vb
0 263 04-11-2016 21:56:36 par Vincent_vb
1 421 16-09-2016 14:06:28 par kcdtv
10 427 29-07-2016 18:10:03 par M1ck3y
18 708 28-06-2016 16:01:14 par kcdtv

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.021 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]