Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 28-04-2012 19:41:26

Kratos96
Membre Actif
Inscription : 11-03-2012
Messages : 43

Patch pour driver ath9k

Bonjour ,
Je cherche un patch pour ma carte wifi Atheros AR9287 qui a le driver ath9k.
Mes recherches m'ont menées jusque içi : http://linuxwireless.org/en/users/Drivers/ath9k
mais je ne trouve pas le lien pour télécharger le driver et je ne vois pas bien comment l'installer.
Une petite aide ne serait pas de refus ^^

Merci
A+

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#2 29-04-2012 18:51:50

kcdtv
Membre d'honneur
Lieu : Internacionaluña
Inscription : 31-03-2010
Messages : 4 246

Re : Patch pour driver ath9k

Ceci n'est pas un patch, mais le driver qui fonctionne avec ton chipset sous linux. 
Note bien qu'il n'y en a pas d'autres, et qu'il est installé de série avec ubuntu. 
Comme tu peux lire sur la page que tu mets en link

It should be noted that some Linux distributions already use the stable compat-wireless releases as packages in their Linux distribution. Examples are ChromeOS, Ubuntu, Gentoo and Openwrt.

Fais bien attentrion au procédé décris sur la page officielle d'aircrack-ng compat wireless,

Installing the package

If you meet the requirements of the package, you can try installing it.
Kernels 2.6.24 or higher

The installation process is as follows:

Download the latest available package from http://wireless.kernel.org/en/users/Download/stable/
$ tar -jxf compat-wireless-3.4-rc1-2.tar.bz2

note: the exact filename of the tarball depends on which version you have downloaded, substitute the example filename with the one corresponding to the file you downloaded
$ cd compat-wireless-3.4-rc1-2

Ça ce sont les drivers, (dont la page officielle c'est le lien que tu mets dans ton post), le package exact dans cet exemple c'est compat-wireless-3.4-rc1-2 (qui contient l'ath9k, notre driver).

Les patches tu les appliques ensuite

$ cd compat-wireless-3.4-rc1-2
 $ wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch
 
 $ patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch

avant de compiler et installer

 $ make
 $ sudo make install
 $ sudo make wlunload
 $ sudo modprobe driver-name

dans notre cas le "driver name" c'est ath9k (qui n'est pas un patch, mais un driver) wink

  Tu peux bien évidement ne rien patcher et utiliser --ignore-negative-one comme nous l'avons vu précédemment.
Pour mémoire:
aircrack-ng résoudre le bug aireplay-ng fixed channel mon0 -1

Hors Ligne

#3 29-04-2012 20:07:10

Kratos96
Membre Actif
Inscription : 11-03-2012
Messages : 43

Re : Patch pour driver ath9k

Salut, je sais que je peut utiliser --ignore-negative-one mais je continue d'avoir le message d'erreur donc il ne sert à rien ^^
Même si ça ne risque pas de résoudre mon problème je veut quand même essayer smile

Le patch que je dois télécharger c'est bien le "compat-wireless-3.4-rc3-1.tar.bz2", c'est à dire le dernier ?

$ cd compat-wireless-3.4-rc1-2
 $ wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch
 
 $ patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch

Et pour ces commandes, je remplace juste compat-wireless-3.4-rc1-2 par compat-wireless-3.4-rc3-1.tar.bz2 ?

Merci
A+

Hors Ligne

#4 30-04-2012 09:53:19

kcdtv
Membre d'honneur
Lieu : Internacionaluña
Inscription : 31-03-2010
Messages : 4 246

Re : Patch pour driver ath9k

kratos a écrit :

Salut, je sais que je peut utiliser --ignore-negative-one mais je continue d'avoir le message d'erreur donc il ne sert à rien

Si tu continu à avoir le message d'erreur "channel -1" c'est que tu n'as pas suivit le tuto de noireaude. Normal que rien ne fonctionne.
Si tu te réfère au message d'erreur concernant ta fausse association, ça n'a rien à voir.

Le patch que je dois télécharger c'est bien le "compat-wireless-3.4-rc3-1.tar.bz2", c'est à dire le dernier ?

Non. encore une fois, compat-wireless n'est pas un patch mais le pack de drivers qui contient l'ath9k.
le patch a tu l'as là ou il est écrit "patch", la ligne en dessous.

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.023 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]