Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 20-12-2012 03:26:10

lip
Nouveau membre
Inscription : 20-12-2012
Messages : 7

Problème de connexion wifi sur BT 5

Salut à tous,

J'ai un problème de connexion à mon réseau wifi avec BT 5 r3. Je précise que la clé bonne, et que le problème ne vient pas de ma box puisque je n'ai aucun problème sous Ubuntu 12.04, ni sous Windows.

En réalité BT se connecte et m'attribue une ip, mais pas moyen d'accéder à la moindre page internet, les pings échouent. J'ai donc poussé plus loin les recherches grace à Etheape, il semblerait que le DNS ne fonctionne pas sad C'est très bizarre.

Auriez vous une solution ?

Merci d'avance

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#2 20-12-2012 09:27:55

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Problème de connexion wifi sur BT 5

Salut, bienvenue sur le forum smile

Règle de base, pour tester sa connectivité, on lance un ping avec une adresse IP et pas un nom de domaine, justement pour court-circuiter un problème de DNS wink

ping 8.8.8.8

Dans ton cas, tu peux ajouter le DNS de Google via la commande suivante :

echo nameserver 8.8.8.8 > /etc/resolv.conf

Je ne sais pas pourquoi BT5 ne les a pas reçus directement de ta Box, ce n'est pas la première fois que je vois ce problème en plus... hmm

Tu utilises quel programme pour te connecter ? Wicd ? Si je me souviens bien, il y a un endroit dans les options où tu peux spécifier quels DNS il doit utiliser wink

Hors Ligne

#3 20-12-2012 10:22:35

lip
Nouveau membre
Inscription : 20-12-2012
Messages : 7

Re : Problème de connexion wifi sur BT 5

Merci beaucoup pour ta réponse Antares.

Oui bizarre que j'ai pas reçu le DNS de ma box. J'utilise wicd pour me connecter. J'avais essayé de fixer manuellement les ip, DNS, et tout et tout en prenant exemple sur les infos de connexion sur Ubuntu mais ça n'a pas l'air de fonctionner. J'essaie ton astuce et je te tiens au courant.

Encore merci

Hors Ligne

#4 20-12-2012 10:37:47

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Problème de connexion wifi sur BT 5

Pour fixer manuellement les paramètres (ça pourra peut-être servir au suivant) wink

# Régler l'IP 192.168.1.42 (le netmask est "classique" pour un réseau domestique)
ifconfig wlan0 192.168.1.42 netmask 255.255.255.0
# Régler la passerelle (la box, typiquement)
route add default gw 192.168.1.1
# Régler les DNS
echo "nameserver 8.8.8.8" > /etc/resolv.conf

Je suppose ici qu'on est déjà connecté au réseau WiFi. Pour se connecter à un réseau en ligne de commande, voir cet autre topic --> Se connecter en wifi sans interface graphique

Dernière modification par antares145 (20-12-2012 10:38:59)

Hors Ligne

#5 20-12-2012 10:47:40

lip
Nouveau membre
Inscription : 20-12-2012
Messages : 7

Re : Problème de connexion wifi sur BT 5

Voici le résultat des tests : ça ne marche pas sad

Je joins des screens shots pour te montrer ce qu'il se passe

ping

etherape

Je comprends pas trop ce qu'il se passe à vrai dire sad

Hors Ligne

#6 20-12-2012 12:11:23

abradacabra
Membre Hyperactif
Inscription : 18-12-2012
Messages : 47

Re : Problème de connexion wifi sur BT 5

C'est pas à cause du signal ?  37%  c'est très faible !

Hors Ligne

#7 20-12-2012 12:32:42

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Problème de connexion wifi sur BT 5

Essaie d'ajouter la commande de route, comme indiqué dans mon deuxième post :

route add default gw 192.168.2.1
# Adapte vace lIP de ta box au besoin

Celle-là est rarement manquante sur BT5, je fus surpris hmm

Si ça ne fonctionne toujours pas, il nous faudrait le résultat des commandes suivantes :

iwconfig
ifconfig
route
cat /etc/resolv.conf

Est-ce qu'un "ping" en local (p-ex directement vers l'IP de ta box) fonctionne ?

@abracadabra : bien vu pour le signal, même si je pense que 40% devraient être suffisant pour joindre le réseau (le message "unreachable" me fait penser qu'il y a un problème de config') wink

Hors Ligne

#8 20-12-2012 14:40:08

lip
Nouveau membre
Inscription : 20-12-2012
Messages : 7

Re : Problème de connexion wifi sur BT 5

D'abord merci à vous deux pour vos réponses.

J'ai rajouté la gateway via la commande route comme tu me l'as conseillé, attribué manuellement IP et netmask, calé mon DNS sur 8.8.8.8 dans le resolv.conf.

Résultat : Marche toujours pas

Le ping local vers la box ne répond, netcat sur le port 80 de la box non plus. pourtant la connexion est établie.

nc 192.168.2.1 80

puissance

Et non ce n'est pas un problème de puissance du signal, puisque d'habitude je me trouve autour des 60% et que ça fonctionne sans soucis sur d'autres OS.

Je donne ici les résultats renvoyés par ifconfig et iwconfig

IFCONFIG :

wlan0     Link encap:Ethernet  HWaddr **:**:**:**:**:**  
          inet addr:192.168.2.104  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::7ae4:ff:fe76:f2b0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:121 errors:0 dropped:0 overruns:0 frame:0
          TX packets:242 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5682 (5.6 KB)  TX bytes:26461 (26.4 KB)

IWCONFIG :

wlan0     IEEE 802.11bgn  ESSID:"BR-Point"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: **:**:**:**:**:**   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key: ***************************
          Power Management:on
          Link Quality=30/70  Signal level=-80 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:78  Invalid misc:383   Missed beacon:0

Je reboot pour récupérer le résultat de route et le fichier resolv.conf.

Hors Ligne

#9 20-12-2012 17:31:51

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Problème de connexion wifi sur BT 5

lip a écrit :

Et non ce n'est pas un problème de puissance du signal, puisque d'habitude je me trouve autour des 60% et que ça fonctionne sans soucis sur d'autres OS.

C'est plus compliqué que ça... D'un OS à l'autre, le pilote utilisé n'est pas le même, et suivant la qualité dudit pilote la réception sera plus ou moins bonne. Si le signal est effectivement bon la différence est faible, mais si le signal est mauvais à la base, ça peut faire la différence wink

Regarde le résultat de ton iwconfig :

wlan0     IEEE 802.11bgn  ESSID:"BR-Point" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: **:**:**:**:**:**   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key: ***************************
          Power Management:on
          Link Quality=30/70  Signal level=-80 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:78  Invalid misc:383   Missed beacon:0

Débit faible (1 Mbit/s), niveau de signal faible (-80 dBm), et beaucoup d'erreurs de transmission (TX retries, invalid). Il y a un problème dans la liaison "physique", même si ce n'est pas le cas avec d'autres OS. Ton réseau est sur un canal peu occupé ou pas ? Si tu te rapproches de la source, ça s'améliore ? T'as quoi comme carte WiFi, en fait ("lspci -nn" pour les infos complètes) ?

Tu peux essayer de pousser un peu ton TX Power (puissance d'émission) mais je doute que ça change beaucoup de choses. Enfin, ça ne coûte rien d'essayer :

iwconfig wlan0 txpower 20
# Si c'est refusé essaye avec 19, 18, 17, 16

Alors je sais que BackTrack ou Ubuntu ça devrait donner les mêmes résultats, mais BT utilise des drivers spécialement patchés pour l'injection et les attaques, et ça se fait parfois au détriment des performances en utilisation "normale" hmm Tu utilises quelle version exactement (Gnome 32/64 bits) ?

PS : le WEP c'est le mal tongue

Dernière modification par antares145 (20-12-2012 17:33:12)

Hors Ligne

#10 20-12-2012 19:32:32

lip
Nouveau membre
Inscription : 20-12-2012
Messages : 7

Re : Problème de connexion wifi sur BT 5

Waou, ça fait plaisir d'avoir les conseils de quelqu'un de compétent big_smile Merci Antares.

Je suis sous BT 5 R3 gnome 32 bits. Mais les résultats ne sont pas forcément les mêmes puisque BT5 est basé sur la 10.04, donc c'est encore du gnome 2, et Ubuntu a beaucoup évolué structurellement jusqu'à la 12.04. Mais du coup je me suis dit que ce serait intéressant de voir le résultat du iwconfig de la 12.04 pour comparer sur le même réseau. Voilà le résultat :

wlan0     IEEE 802.11bgn  ESSID:"BR-Point"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: **:**:**:**:**:**   
          Bit Rate=36 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=37/70  Signal level=-73 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2  Invalid misc:658   Missed beacon:0


Ma carte wifi d'après le lspci :

02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Sinon je pensais peut-être tenter une réinstallation de BT5 ? Ca servirait à quelque chose d'après toi ?

PS : le WEP c'est le mal tongue

-> ça dépend pour qui :noel:

Dernière modification par lip (20-12-2012 19:33:44)

Hors Ligne

#11 20-12-2012 22:56:34

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Problème de connexion wifi sur BT 5

lip a écrit :

Waou, ça fait plaisir d'avoir les conseils de quelqu'un de compétent big_smile

Heu, attends que j'aie commencé à régler le problème avant de te prononcer sur mes compétences big_smile

Bien bien bien. Une Atheros récente, donc. Ca tombe bien ça devrait être correctement supporté. Au passage, pense à donner l'option "-nn" à lspci, pour qu'on puisse avoir le code-matériel complet (genre [1022:1103]), c'est le mieux pour identifier le matériel wink

La connexion est à peine meilleure (-73 dBm au lieu de -81), mais ça suffit visiblement à transformer la connexion en quelque chose d'utilisable. Curieux. Tu peux essayer de forcer le bitrate, mais je doute que ça résolve tout d'un coup :

iwconfig wlan0 rate 36M
# Pour revenir au réglage par défaut : 
#iwconfig wlan0 rate auto

Tu remarqueras que le nombre de paquets invalides reste élevé même sur Ubuntu, t'as essayé de changer de canal ? Ton canal 11 actuel fait souvent partie des plus encombrés (avec le 1 et le 6)... Ah, et comment ça se fait que tu as "encryption:off", tu as désactivé la sécurité pour tester sur Ubuntu ?

Là je t'avoue que je sèche un peu. La version Gnome64 avait certains bugs du côté de Wicd, mais ça n'a pas l'air d'être le problème ici. C'est comme si le pilote se comportait notoirement moins bien sous BT (ce qui était prévisible, mais pas à ce point-là). Une réinstallation ne changera sans doute rien (sauf si ça fonctionnait correctement au début). Par contre, tu peux faire une mise-à-jour complète et prier pour que le problème soit réglé (perso j'y crois pas trop mais bon).

apt-get update
apt-get dist-upgrade

Une autre solution, c'est de continuer à utiliser Ubuntu et y installer les outils de BackTrack dont tu as besoin wink

lip a écrit :
PS : le WEP c'est le mal tongue

-> ça dépend pour qui :noel:

Comme tu as bien lu le règlement et que tu fais des tests sur TON réseau, le WEP n'a pas d'intérêt chez toi (sauf pour le cracker évidemment) tongue

Hors Ligne

#12 21-12-2012 00:20:19

lip
Nouveau membre
Inscription : 20-12-2012
Messages : 7

Re : Problème de connexion wifi sur BT 5

Oui ce serait une solution. Y a-t-il une méthode pour ajouter tous les outils de BT 5 sur la 12.04 ? J'avais trouvé un article sur le net en passant par un ajout de dépôt mais ça marchait pas vraiment, plein d'ouils étaient foireux.

Hors Ligne

#13 21-12-2012 13:26:25

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Problème de connexion wifi sur BT 5

Heu, je ne te conseille pas de vouloir transformer ton Ubuntu en BackTrack hmm L'intégration des outils passe par toute une série de détails genre l'installation de postgresql ou l'utilisation de versions bien précises de Ruby pour Metasploit. Les développeurs de BackTrack trouvent ça "trivial et évident", mais ce n'est pas à la portée d'un débutant voire d'un utilisateur "normal" (ils le revendiquent et ils en sont fiers).

De toute façon, je doute que tu aies besoin de tous les outils de BackTrack, installe juste ceux dont tu as besoin (genre la suite aircrack-ng ou Metasploit). Pour une utilisation ponctuelle, tu peux utiliser une machine virtuelle (qui utilise la connexion Internet du système hôte donc pas de problème de WiFi) wink

Si tu veux un coup de main pour installer des outils en particulier, ouvre un nouveau topic du genre "Installer des outils BackTrack sur Ubuntu"), on en discutera là-bas.

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Sujets similaires

Discussion Réponses Vues Dernier message
Quelle carte wifi choisir ? par Morpheus_Dotcom
2 125 05-12-2016 15:11:00 par Morpheus_Dotcom
4 220 04-12-2016 16:20:59 par pwerrick
8 307 17-11-2016 12:02:17 par koala
Problème reaver par Antho3674
4 314 15-11-2016 22:05:12 par kcdtv
0 287 22-10-2016 19:03:48 par Antho3674

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.054 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]