Crack-wifi.com FORUM

LE FORUM DU SITE

Wifi, Backtrack, crack WEP et WPA...

Vous n'êtes pas identifié(e).  

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#1 05-05-2013 07:06:39

Fuji
Membre Irremplaçable
Lieu : Saint Script-sur-Shell
Inscription : 13-12-2010
Messages : 783

Rogue: redirection du trafic

J'ai du mal à faire une petite jonction avec un fake ap délivrant une page web avec BackTrack et le tout sur un seul ordi. BT est installée au sein de VMware qui est à son tour sur Windows connecté à un HotSpot, pas de box, voici un peu la manip:

Une carte Alfa est connectée à BT et une carte interne de Windows à un Hotspot. Une fois le faux réseau crée avec airbase-ng et la mise en place d'un DHCP avec "udhcpd", je déconnecte Windows de son Hotspot pour le ramener sur le faux réseau et à ce niveau là tout va bien. Sauf que je n'arrive pas à tomber sur la page html, en fait je n'utilise pas le serveur Apache mais Netcat:

cat page.htm | nc -vlp 80

La configuration de eth0 est:

IP   192.168.233.129 
GW 192.168.233.255 + 255.255.255.0

Pour at0, je lui est assigné une IP 192.168.233.131 et la même passerelle que eth0.

Pour le DHCP:

max_leases 10
start 192.168.233.10
end 192.168.233.20
interface at0
domain wifi
option dns 8.8.8.8
option subnet 255.255.255.0
option router 192.168.233.255
lease 7200

Un coup de forward:

echo 1 > /proc/sys/net/ipv4/ip_forward

Je redirige vers le port 80 de eth0 où nc est en écoute pour y trouver la page:

iptables -t nat -A PREROUTING -p tcp --dport 80 -j DNAT --to 192.168.233.129:80

C'est sur cette règle que j'ai des doutes, si j'indique une url comme Google pour aller directement sur le port 80, et bien ça bloque. J'arrive pas à voir clair entre les adresses et iptables, le DNS a quelque chose à voir aussi ? le tout étant en local sur un seul ordi, un peu comme les mains se dessinant d'Escher wink

Dernière modification par Fuji (05-05-2013 07:08:42)

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

#2 05-05-2013 11:25:25

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Rogue: redirection du trafic

Salut ! smile

Bon, déjà le coup de l'escalier de Penrose, je suis pas convaincu, y a trop moyen que ça fasse foirer le tout pour une obscure raison de routage circulaire. Même si à priori, je ne peux pas dire exactement ce qui foirerait tongue

Petites vérifications d'abord, est-ce que ton airbase-ng et ton DHCP fonctionnent correctement ? Ta "victime" reçoit bien une IP valide et peut-elle ping'er sa passerelle (j'ai un doute là, ptet que VMWare bloque le ping).

Ensuite, tu as une bonne raison de ne pas vouloir utiliser de serveur web ? Même si ça devrait fonctionner partiellement avec Netcat, tu ne pourras faire qu'une seule requête donc tu n'auras qu'une partie du contenu de la page (typiquement, ton CSS tu peux l'oublier) wink

La règle Iptable a l'air bonne, et normalement le DNS n'a pas d'influence sur son fonctionnement. Si tu tapes directement "192.168.233.129" dans la barre d'adresse de ta victime, est-ce que la page s'affiche ?
Et c'est quoi que tu entends par "et bien ça bloque" ? Erreur de connexion, erreur de DNS, page blanche, plantage du navigateur,... ?

Dernière modification par antares145 (05-05-2013 11:25:59)

Hors Ligne

#3 06-05-2013 03:33:07

Fuji
Membre Irremplaçable
Lieu : Saint Script-sur-Shell
Inscription : 13-12-2010
Messages : 783

Re : Rogue: redirection du trafic

En fait, lorsqu'on se connecte à un Hotspot et si on clique sur Google, Hotmail ou Crack-wifi c'est la page d’authentification du Hotspot qui s'affiche en premier, et c'est ce que je n'arrive pas à reproduire. Le navigateur attend longtemps la page puis il affiche le message classique comme si on était pas du tout connecté au Net, c'est pour ça je disais que ça bloque.

C'est effectivement un problème avec "at0", dans "ipconfig" de Windows, il y a une adresse IP 192.168.233.10 et une passerelle 192.168.233.255, c'est exactement comme indiqué dans la configuration du DHCP, et pendant qu'airbase-ng fait tourner le réseau, elle indique bien ensuite une association avec Windows en affichant son adresse MAC. Mais j'arrive pas à ping'er la passerelle hmm t'avais raison.

Pour Netcat, je l'utilise juste comme un Metrix pour vérifier si le courant passe ou pas, et dans mon cas il y a bien un interrupteur ouvert quelque part. Mais comme j'ai la flemme avec les script PHP, etc. afin de récupérer le tout dans un fichier txt. j'utilise deux sockets Netcat qui écoutent: le premier fournit la premiere page, et dans cette derniere le lien vers le second qui indique que la connexion a réussie, en plus que ce dernier netcat affiche la saisie. Pour le CSS et le reste, j’intègre tout dans une seule page, à part l'HTML tout est en base 64 même les images, d'où l'efficacité de Netcat smile

at0       Link encap:Ethernet  HWaddr 00:c0:ca:00:00:00
          inet addr:192.168.233.131  Bcast:192.168.233.255  Mask:255.255.255.0
          inet6 addr: fe8f::fcf:ffff:fefa:f2f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500
          RX bytes:0 (0.0 B)  TX bytes:2520 (2.5 KB)

eth0      Link encap:Ethernet  HWaddr 00:0c:29:00:00:00
          inet addr:192.168.233.129  Bcast:192.168.233.255  Mask:255.255.255.0
          inet6 addr:fe8f::fcf:ffff:fefa:f2f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2916 errors:0 dropped:0 overruns:0 frame:0
          TX packets:182 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:289338 (289.3 KB)  TX bytes:19197 (19.1 KB)
          Interrupt:19 Base address:0x2024

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:730 (730.0 B)  TX bytes:730 (730.0 B)

mon0      Link encap:UNSPEC  HWaddr 00-C0-CA-00-00-00-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST NOTRAILERS RUNNING PROMISC ALLMULTI  MTU:1800  Metric:1
          RX packets:64082 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13142852 (13.1 MB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:c0:ca:00:00:00
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.233.0   *               255.255.255.0   U     0      0        0 eth0
192.168.233.0   *               255.255.255.0   U     0      0        0 at0
default         192.168.233.2   0.0.0.0         UG    100    0        0 eth0

PS: at0 est considérée comme une interface wifi ou ethernet ?

Dernière modification par Fuji (06-05-2013 17:35:45)

Hors Ligne

#4 12-05-2013 19:24:21

antares145
Membre d'honneur
Inscription : 29-09-2009
Messages : 5 199
Site Web

Re : Rogue: redirection du trafic

Fuji a écrit :

PS: at0 est considérée comme une interface wifi ou ethernet ?

Ethernet (classique), si tu regardes dans "iwconfig" tu verras qu'elle n'est pas prise en charge. Mais ça ne devrait pas être l'origine du problème ici...

Ton setup est déjà complexe en soi (même si je trouve la solution du double netcat très élégante), alors le déployer en plus sur la même machine "physique" j'ai peur que ce soit se compliquer la tâche pour rien... Tu devrais essayer de séparer au moins les machines, pour éliminer les problèmes potentiels dus à la virtualisation. Le ping par exemple, impossible de savoir s'il ne fonctionne pas à cause d'un problème réseau ou bien parce que cette fonctionnalité est désactivée par la VM...

Et je maintiens qu'essayer de monter un portail captif sans serveur web, c'est casse-gue*le. Beau challenge technique, mais casse-gue*le big_smile

Hors Ligne

Annonce

Visitez la boutique Wifi-highpower.com, votre revendeur agr Alfa Network: du matriel Wifi slectionn, cartes Wifi USB Awus036h et Awus036nh, antennes omnis, yagis, panel, amplis wifi, accessoires...

Sujets similaires

Discussion Réponses Vues Dernier message
106 2220 28-11-2016 19:42:10 par koala
35 1880 23-11-2016 16:31:33 par roofnat
16 1055 17-11-2016 12:22:00 par disquette
10 445 11-11-2016 22:11:03 par koala
[ Projet Rogue AP ] par shirocen
16 456 19-10-2016 05:14:45 par shirocen

Pied de page des forums


Le coin des bonnes affaires, achats informatiques:


|   Alfa 1000 mW AWUS036H   |    Linksys WRT54GL   |    Misco, informatique   |   
 |    Ebay   |    PC portables   |    PC Gamers & Tuning   |    Cles USB   |   
|   Disques durs externes 2 To   |   
|   Wifi-highpower.com   |   


Server Stats - [ Generated in 0.022 seconds ]   Forum Stat - [ Most users ever online on the forum was : 150 on 20-09-2009 17:06:59 ]